Xin giúp đỡ về router trong mô hình mạng

Thảo luận trong 'Infrastructure security' bắt đầu bởi Minh dũng, 17/01/19, 11:01 PM.

  1. Minh dũng

    Minh dũng Member

    Tham gia: 05/12/17, 03:12 PM
    Bài viết: 17
    Đã được thích: 1
    Điểm thành tích:
    3
    e đang có 1 mạng kết nối Internet bình thường, qua modem VNPT ( ko có ip tĩnh).
    bây giờ e có 1 thiết bị router cisco 2 cổng wan.
    Yêu cầu:
    e muốn thiết lập làm sao để các máy trong mạng có thể truy cập Internet và truy cập wan về máy server có địa chỉ là 192.168.1.x.
    các PC trong mạng được modem cấp DHCP với dải mình muốn ( trường hợp này là 192.168.100.x ):
    E cần cấu hình router như thế nào để có thể đáp ứng yêu cầu trên ah?
    interface GigabitEthernet0/0/0
    ip address 10.4.6.254 255.255.255.0
    negotiation auto
    !
    interface GigabitEthernet0/0/1
    ip address 192.168.1.253 255.255.255.0
    negotiation auto upload_2019-1-17_23-46-7.png
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  2. DiepNV88

    DiepNV88 Super Moderator Thành viên BQT

    Tham gia: 24/09/13, 03:09 AM
    Bài viết: 1,359
    Đã được thích: 247
    Điểm thành tích:
    63
    Route của bạn có 2 cổng serial, theo mô hình trên cổng Gig0/0/0 bạn set ip cho cổng trùng dải của mạng pc, cổng Gig0/0/1 bạn set ip cùng dải của server sau đó routing 2 mạng trên để có thể ping thông từ pc đến server nếu bạn chưa học CCNA thì có thể tham khảo các video hương dẫn cấu hình ví dụ:
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  3. nktung

    nktung Super Moderator Thành viên BQT

    Tham gia: 08/10/13, 04:10 AM
    Bài viết: 804
    Đã được thích: 305
    Điểm thành tích:
    83
    Trên Router em cần config định tuyến tĩnh mặc định (default static route) với next-hop là IP của MODEM. Còn mạng WAN em cấu hình định tuyến tĩnh như cách thông thường. Như vậy mỗi khi user ra Internet, gói tin sẽ đi tới Router, sau đó router sẽ định tuyến ra Modem. Còn vào wan thì gửi theo định tuyến tĩnh thông thường.
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
    whf thích bài này.
  4. Minh dũng

    Minh dũng Member

    Tham gia: 05/12/17, 03:12 PM
    Bài viết: 17
    Đã được thích: 1
    Điểm thành tích:
    3
    hj, cảm ơn các anh đã giúp đỡ ah.
    e Làm như anh NTKTUNG đã nói thì bài lap đã hoàn thành - PC ra được Internet và Ping được về server, đây là file config của e ah:
    interface GigabitEthernet0/0/0
    ip address 192.168.100.254 255.255.255.0
    ip nat inside
    negotiation auto
    !
    interface GigabitEthernet0/0/1
    ip address 192.168.1.254 255.255
    ip nat outside
    negotiation auto

    ip route 0.0.0.0 0.0.0.0 192.168.100.1 // địa chỉ modem.

    tuy nhiên e làm như vậy thì e sẽ cần đặt ip tĩnh cho các PC - trỏ default-gateway về port g0/0/0 ( 192.168.100.254) và trên Server thì phải trỏ default-gateway về port g0/0/1 ( 192.168.1.254). Server cũng không ra được INTERNET.
    - Mạng wan e chưa cần phải tuyến tĩnh gì cả: iproute 192.168.1.0 255.255.255.0 g0/0/0

    E hỏi chút là còn cách nào có thể cho PC nhận được DHCP ( từ modem hoặc router) được không ah ? và Server cũng ra được INTERNET ?
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  5. Minh dũng

    Minh dũng Member

    Tham gia: 05/12/17, 03:12 PM
    Bài viết: 17
    Đã được thích: 1
    Điểm thành tích:
    3
    hj cảm ơn bạn. mô hình trên của mình có 1 router, 1 đường wan , 1 modem , riêng modem không thiết đặt được default-gateway bạn ah. Ý mình hỏi là các PC sẽ ra truy cập ra 2 đường Internet qua modem và qua router về wan. hjx, đang gặp nhiều vấn đề quá
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  6. nktung

    nktung Super Moderator Thành viên BQT

    Tham gia: 08/10/13, 04:10 AM
    Bài viết: 804
    Đã được thích: 305
    Điểm thành tích:
    83
    Em cấu hình Router cấp phát IP động cho các máy PC nhé
    Server chắc chắn ra được Internet, nhưng anh không hiểu về mô hình của em là tại sao Server trong mạng nội bộ (Intranet) mà em lại phải NAT?
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  7. Minh dũng

    Minh dũng Member

    Tham gia: 05/12/17, 03:12 PM
    Bài viết: 17
    Đã được thích: 1
    Điểm thành tích:
    3
    hj a NTKTUNG ah. e chưa NAT đâu a ah, mới đầu e định như thế.
    e thử cấp DHCP trên router thì Ok rồi ah. Tuy nhiên còn Server thì e ko đi ra được Internet, trên modem có chức năng Advanced Routing ,e đã routing cho về mạng của server 192.168.1.0, khi đó Server ping được về địa chỉ của Modem nhưng vẫn không ra được INTERNET a ah.
    Test: ping địa chỉ MODEM source 192.168.1.254 thì OK
    ping địa chỉ 8.8.8.8 source 192.168.1.254 thì NOT OK ah.
    - Một điều nữa e muốn hỏi a là , e có thể để default-gateway trên Server là 192.168.1.1 được không ah ? nếu để như vậy thì phải cấu hình làm sao để PC vẫn ping được về Server mà ko phải đổi địa chỉ 192.168.1.254 của cổng g0/0/1 Router ah?
    e đang làm trên thiết bị thật đó ah.
    Cảm ơn a đã giúp đỡ ah.
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  8. nktung

    nktung Super Moderator Thành viên BQT

    Tham gia: 08/10/13, 04:10 AM
    Bài viết: 804
    Đã được thích: 305
    Điểm thành tích:
    83
    Hi bạn
    Các máy trong mạng LAN có ra được Internet không em?
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  9. Minh dũng

    Minh dũng Member

    Tham gia: 05/12/17, 03:12 PM
    Bài viết: 17
    Đã được thích: 1
    Điểm thành tích:
    3
    có anh ah, các máy PC trong Lan vẫn ra Internet bình thường ah
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  10. nktung

    nktung Super Moderator Thành viên BQT

    Tham gia: 08/10/13, 04:10 AM
    Bài viết: 804
    Đã được thích: 305
    Điểm thành tích:
    83
    Vậy thì nguyên nhân nằm ở Router hoặc ở Server thôi, em check kỹ lại đi
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  11. nktung

    nktung Super Moderator Thành viên BQT

    Tham gia: 08/10/13, 04:10 AM
    Bài viết: 804
    Đã được thích: 305
    Điểm thành tích:
    83
    Em copy cấu hình router ra đây a check cho
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  12. Minh dũng

    Minh dũng Member

    Tham gia: 05/12/17, 03:12 PM
    Bài viết: 17
    Đã được thích: 1
    Điểm thành tích:
    3
    hj a NTKTUNG. từ hôm rồi nghỉ tết e cũng chưa vào lại diễn đàn, e cảm ơn a đã giúp đỡ ah.
    e đã tạm thiết lập với cấu hình như bên dưới. mọi thứ đều ổn, duy chỉ có server ( địa chỉ gateway 192.168.1.254) không ra internet được thôi ah.

    Đây là nội dung file cấu hình trên router:
    interface GigabitEthernet0/0/0
    ip address 192.168.100.254 255.255.255.0
    ip nat inside
    negotiation auto
    !
    interface GigabitEthernet0/0/1
    ip address 192.168.1.254 255.255
    ip nat outside
    negotiation auto

    ip dhcp pool inside
    network 192.168.100.0 255.255.255.0
    default-router 192.168.100.254

    ip route 0.0.0.0 0.0.0.0 192.168.100.1 // địa chỉ modem IGate của VNPT.
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan
  13. nktung

    nktung Super Moderator Thành viên BQT

    Tham gia: 08/10/13, 04:10 AM
    Bài viết: 804
    Đã được thích: 305
    Điểm thành tích:
    83
    Em bỏ 2 câu lệnh NAT đi
     
    Lưu ý từ WhiteHat: Kiến thức an ninh mạng để phòng chống, không làm điều xấu. Luật pháp liên quan